D 7.5
DELIVERABLE

PROJECT INFORMATION

Project Title: Systemic Seismic Vulnerability and Risk Analysis for Buildings, Lifeline Networks and Infrastructures Safety Gain

Acronym: SYNER-G

Project N°: 244061

Call N°: FP7-ENV-2009-1

Project start: 01 November 2009

Duration: 36 months

DELIVERABLE INFORMATION

Deliverable Title: D7.5 – MCDA Software

Date of issue: 15 March 2013

Work Package: WP7 – Software

Deliverable/Task Leader: Karlsruhe Institute of Technology

Reviewer: 

REVISION: Final

Project Coordinator:
Institution: Aristotle University of Thessaloniki

e-mail: kpiti1ak@civil.auth.gr
fax: + 30 2310 995619
telephone: + 30 2310 995693
Abstract

MCDA is a Java-based software for multiple criteria decision. Decision support for emergency management involves resolving conflicting objectives, setting priorities and building consensus for the various perspectives of the many stakeholder groups. MAVT (Multi-Attribute Value Theory) is a MCDM framework that provides methods to structure and analyse problems by means of attribute trees and to elicit the relative importance of the criteria in such a tree. Particularly, in the context of modelling shelter needs in SYNER-G the MCDA software will allow the stakeholders display the indicators that are used in the Shelter Model using various output and visualizations formats. To facilitate the weighting assignment process, the MCDA tool will allow the stakeholders to change and manipulate the existing weights and interactively investigate the changes upon the total ranking outcome of shelter needs. The implementation of the shelter model has been tested and validated with the use the MCDA software, which was found to be a flexible and practical analytical platform for duplicating methodology. The software supports performing sensitivity analyses, which can be used to interactively demonstrate variability of the results to different indicators. It also enables an evaluation of the stability of the methodology to variability of the input data. The advantage of using such a tool is that it integrates the outputs of different physical risk models and that other indicators that may have previously not been available or simply overlooked in a previous analysis can be integrated into the framework interactively to obtain a new evaluation of shelter needs.

The software was developed at KIT starting September 2010 to present by Susan Vaziri Elahi and Tim Mueller at the Institute for Nuclear and Energy Technologies (IKET), KIT. An interface from the outputs from the OOFIMS software to the MCDA tool was developed by VCE in EQViz. The following document describes 1) a general introduction to MCDA; 2) how to install the MCDA tool, 3) the interface between OOFIMS and MCDA in EQViz and 4) a tutorial for implementing the shelter needs model in the MCDA tool.

Keywords: MCDA, Indicators, Toolkit, Decision Support, Shelter Needs
Acknowledgments

The research leading to these results has received funding from the European Community's Seventh Framework Programme [FP7/2007-2013] under grant agreement n° 244061. The MCDA software was developed at KIT starting September 2010 to present by Susan Vaziri Elahi and Tim Mueller at the Institute for Nuclear and Energy Technologies (IKET), KIT.
Deliverable Contributors

KIT  Bijan Khazai  Sections 1 and 4
     Tim Mueller
     Susan Vaziri

VCE  David Schaefer  Sections 2 and 3
# Table of Contents

1 Introduction ....................................................................................................................... 1  
   1.1 OVERVIEW OF MCDA SOFTWARE .......................................................................... 1  
   1.2 OVERVIEW OF MCDA FRAMEWORK ...................................................................... 1  
   1.3 DEFINITION OF TERMS USED IN MCDA ................................................................. 2  

2 Installing the MCDA Tool .................................................................................................. 3  
   2.1 BASIC REQUIREMENTS FOR INSTALLING MCDA TOOL ....................................... 3  
   2.2 QUICK STEP BY STEP GUIDE FOR INSTALLING MCDA ........................................ 3  

3 MCDA Software Interface in EQvis .................................................................................. 1  
   3.1 LINKS TO OOFIMS OUTPUTS (I.E. VISUALIZATION OF SIMULATIONS) (VCE).... 1  
      3.1.1 Reading the OOFIMS Outputs ........................................................................ 1  
      3.1.2 Create Intersections ..................................................................................... 1  
      3.1.3 Create MCDA SCDS .................................................................................... 3  
   3.2 USING THE INPUT INTERFACE IN THE SYNER-G PLATFORM TO LAUNCH  
      MCDA (VCE) ......................................................................................................... 4  
      3.2.1 MCDA Input ................................................................................................ 4  

4 MCDA Software Tutorial ................................................................................................... 1  
   4.1 SHELTER NEEDS MODEL ........................................................................................ 1  
   4.2 STEPS IN DEVELOPING THE MODEL ..................................................................... 2  
   4.3 IMPLEMENTING THE MODEL IN MCDA SOFTWARE .............................................. 2  
      4.3.1 Theroetical concept - Creating the Decision Tree ....................................... 2  
      4.3.2 Populating the Data Matrix ........................................................................ 4  
      4.3.3 Normalization ............................................................................................. 4  
      4.3.4 Aggregation of Decision Criteria .................................................................. 5  
      4.3.5 Assigning Weights ..................................................................................... 6  
   4.4 DISPLAYING RESULTS ............................................................................................ 7  
      4.4.1 Stacked Bar Chart ....................................................................................... 7  
      4.4.2 Criteria Importance .................................................................................... 8  
      4.4.3 Analyzing Stability of Analysis .................................................................... 9
List of Figures

Figure 1 The Analysis “Read OOFIMS Output” (left), sample Dataset (right) ....................... 1
Figure 2 The Analysis “Create Intersections” (left), sample Dataset (right) ......................... 2
Figure 3 The Analysis “Create MCDA SCDS” (left), sample Dataset (right) ......................... 3
Figure 4 The Analysis “MCDA Input” (left), starting screen of MCDA (right) ...................... 4
Figure 5 Decision criteria for computing Shelter Needs Index (SNI) .................................... 1
Figure 6 Methodological steps of the development of a hierarchical indicator framework ...... 2
Figure 7 Hierarchical Decision Criteria of Shelter Needs Model developed in MCDA using the “Tree View” .................................................................................................. 3
Figure 8 Hierarchical Data Matrix in MCDA which can be used to enter, and edit the raw and normalized value of each of the criteria measures ........................................... 4
Figure 9 The Criterion Value Function Dialogue Box which can be used to define the shape of the normalization curve of each selected criteria measure ................................. 5
Figure 10 The criteria aggregator dialogue box, which can be used to define the aggregation relationship for each criteria as "weighted sum", "weighted product" or a "mathematical expression/formula" defined by the user .............................................. 6
Figure 11 The interactive importance/weight dialogue box which can be used to change the weights of each of the criteria measures on the fly........................................... 6
Figure 12 The stacked bar ranking for SNI displayed up to tier 1 ........................................... 7
Figure 13 Sorted stacked bar ranking of SNI displayed up to tier 2 ....................................... 8
Figure 14 Cob-web chart showing the distribution of the criteria weights for all of SNI measures at one glance ............................................................ 8
Figure 15 Pie charts showing each the product of the weights and values for all of the alternatives ................................................................. 9
Figure 16 A sensitivity graph in MCDA showing the sensitivity of the alternative’s ranking to the weights of DPI ................................................................. 10
List of Tables

No table of figures entries found.
1 Introduction

1.1 OVERVIEW OF MCDA SOFTWARE

MCDA is a Java-based software for multiple criteria decision. In decision making problem
the decision maker has some alternatives and some criteria on which the decision is based.
In MCDA the problem is structured hierarchically to form a value tree. In this value tree each
critereum is divided to its subcriteria, which are weighted by their importance to decision
maker (On the lowest level criteria the alternatives are weighted). The total weights of the
alternatives are calculated from these local weights.

The local weights of criteria and alternatives are given directly or by using some
sophisticated weighting method. MCDA supports an interactive visual weighting method,
where the user can change and manipulate the existing weights and interactively investigate
the changes upon the total ranking outcome in the analysis.

As a result of the decision making problem MCDA gives the total weights of the alternatives.
These weights are shown by bar graphs and bars which can be divided to segments by
contribution of each criterion. There is also a possibility to run a sensitivity analysis, which
gives more information about the sensitivity of the results.

Decision support for emergency management involves resolving conflicting objectives,
setting priorities and building consensus for the various perspectives of the many
stakeholder groups.

The implementation of the shelter model has been tested and validated with the use the
MCDA software, which was found to be a flexible and practical analytical platform for
duplicating methodology. The software supports performing sensitivity analyses, which can
be used to interactively demonstrate variability of the results to different indicators. It also
enables an evaluation of the stability of the methodology to variability of the input data. The
advantage of using such a tool is that it integrates the outputs of different physical risk
models and that other indicators that may have previously not been available or simply
overlooked in a previous analysis can be integrated into the framework interactively to obtain
a new evaluation of shelter needs.

The software was developed at KIT starting September 2010 to present by Susan Vaziri
Elahi and Tim Mueller at the Institute for Nuclear and Energy Technologies (IKET), KIT.

1.2 OVERVIEW OF MCDA FRAMEWORK

MAVT (Multi-Attribute Value Theory) is a MCDA framework that provides methods to
structure and analyse problems by means of attribute trees and to elicit the relative
importance of the criteria in such a tree.

Several key phases of MCDM (resp. of MAVT) are distinguished:
Problem structuring can be described as the process of appropriately formulating rather than solving a problem;

- Better understanding of the problem and the values affecting a decision;
- Basis for further analyses and common language;
- In addition to identifying and specifying objectives (criteria) and attributes as well as decision alternatives, the aim of problem structuring is the hierarchical modelling of the criteria;
- Top-down approach: Strategic approach, starting with the determination of the most general objective which is then successively divided into sub-objectives and – on the lowest level – measurable attributes
- Bottom-up approach: Tactical approach, starting with the identification of measurable attributes in which the performance of the alternatives differs which are then combined and structured into higher level objectives

1.3 DEFINITION OF TERMS USED IN MCDA

Alternatives: possible countermeasure options that might be applicable for our problem

Criteria/Attribute: Means that are important for the decision making process such as consequences/deaths, costs, resources but also acceptance

Attribute trees: tree structure of criteria/attributes that are relevant for the decision making process; result of problem structuring

Preferences/Weights: which of the above mentioned criteria/attributes is more important for my decision making than others.

Final goal: The objective of my process (e.g. reduction of the amount of contaminated milk above a certain level)
2 Installing the MCDA Tool

2.1 BASIC REQUIREMENTS FOR INSTALLING MCDA TOOL

In order to use MCDA comfortably, we recommend the following system requirements:

- Operating system Windows XP Sp3 / Vista / 7
- CPU with 2 GHz
- 2 GB RAM
- 200 MB hard disk capacity
- Graphic card with OpenGL acceleration and a resolution of 1024 x 768 pixels, onboard solutions and shared-memory-technologies are sufficient

When working on large systems, huge amounts of data will be produced. As soon as the main memory is not sufficient for taking the data, the hard drive will take over.

2.2 QUICK STEP BY STEP GUIDE FOR INSTALLING MCDA

Installing the MCDA Tool in EQvis is actually a very easy task. The provided folder called “MCDA” has to be copied to the right folder. Copy the “MCDA” folder to C:\EQvis\.

If you want to start MCDA independently of the EQvis platform, you have to double-click the MCDA-GUI.jar file. MCDA will open.

If you want to start the MCDA tool in EQvis, there are two options, either starting MCDA with the symbol in the left upper side of the platform, or executing analyses before starting MCDA. The first option is more or less the same as starting MCDA directly. The second option will be explained in chapter 4.3.
3 MCDA Software Interface in EQvis

3.1 LINKS TO OOFIMS OUTPUTS (I.E. VISUALIZATION OF SIMULATIONS) (VCE)

OOFIMS produced different outputs in different data files. There are some matlab files, excel files or even figures. All these different files are put together in a GIS shapefile. This is realised in different analyses that the user can perform within the platform. There is a logic behind all these steps which will be shown in this chapter.

3.1.1 Reading the OOFIMS Outputs

This analysis reads the outputs from OOFIMS and stores them internally. The user has to provide the run-number which shall be displayed within the platform, or manually select the files (The user has to provide a folder).

![Figure 1 The Analysis “Read OOFIMS Output” (left), sample Dataset (right)](image)

3.1.2 Create Intersections

This analysis takes the file from the last analysis and intersects the results with the original Sub-City-Districts file. The output of OOFIMS is characterised through cells.
which can be defined prior to the calculations done in OOFIMS. Depending on the size of the cells the results may vary.

![Diagram of intersections](image)

**Figure 2 The Analysis “Create Intersections” (left), sample Dataset (right)**

### 3.1.2.1 Explanation about the calculations

In this small chapter the calculations for the intersections are explained. In Figure 3 one can see a typical case of a cell that is produced by OOFIMS. This cell contains information about building damage, displaced people, etc. This cell does not coincide with the format of the Sub City Districts. It is a completely new grid that is produced. The information has to be transformed into the right geometries, in this case the Building Cell structure, which was the original input in OOFIMS. To realise this, the cells of the OOFIMS output are intersected with the original files geometrically. In Figure 3 one can see a cell (brown) and one line of an original building cell (green area). The calculation is now done via the intersection. The area of the cell is being calculated and the percentage in relation to the whole area is calculated. This percentage is now added to the respective Building Cell it belongs to. This calculation is done for each output cell. In the end for each cell the user gets a transformation of the information into the original Building Cell structure.

This procedure is again performed in the next step of the analysis “Create MCDA SCDS”. The calculated Building Cells now represent the cells and they are being intersected with the original file for Sub City Districts, see chapter 4.2.3.
3.1.3 Create MCDA SCDS

This analysis does not perform new computations. It searches in the datasets for the necessary information that is needed as an input for the MCDA software. This analysis produces a shapefile which can be visualised separately and can be used as an input for the MCDA software.

As previously explained in chapter 4.2.2, the intersection is realised in the same way as the intersection from cells to Building Cells.
3.2 USING THE INPUT INTERFACE IN THE SYNER-G PLATFORM TO LAUNCH MCDA (VCE)

To get to the MCDA Plug-in with the data produced in OOFIMS you may open the “Execute Analysis” window and choose Syner-G MCDA and then “MCDA Input”. This Analysis again divides in the 2 known categories: Required and Optional.

The next field in the required mask is the “Indicators” field. It divides in 4 categories and sets the initial values for each of the categories. Once you have inserted all the necessary information, the Execute button appears green and the analysis can be started. At the end of this analysis the data is automatically loaded in the MCDA input file and MCDA is started.

3.2.1 MCDA Input

This analysis takes the shapefile from the previous task together with some additional information and starts the MCDA software with the requested input. The additional information can be Urban Audit Data, the required indicators and optional information like Shelter Accessibility and various different transformation functions.

Figure 4 The Analysis “MCDA Input” (left), starting screen of MCDA (right)
4 MCDA Software Tutorial

4.1 SHELTER NEEDS MODEL

The integrated shelter needs model developed here is implemented based on the principles of multi-criteria decision theory (MCDA) framework which allows the bringing together of parameters influencing the physical inhabitability of buildings, with social vulnerability (and coping capacity) factors of the at-risk population to determine as well as external factors to determine the desirability to evacuate and seek public shelter. As shown in Figure 5, the multi-criteria framework can be described schematically as composed of the two main criteria: overall population at risk of being displaced after an earthquake (DPI) and the proportion of this population likely to seek public shelter (SSI). The Displaced Persons Index (DPI) is given as occupants in Building Habitability Index (BHI) amplified by external and internal factors related to desirability to evacuate according to Equation 1 (For more on the shelter needs methodology please refer to the SYNER-G Reference Report #5).

\[
DPI = BHI \times (1 + D4)
\]  
Equation 1

Figure 5 Decision criteria for computing Shelter Needs Index (SNI)

Subsequently, the total demand for public shelter for a particular location (i.e., city district) can be described as a product of the population at risk of being displaced (D1, D2 and D3) to the population likely to seek public shelter (D4). This can be expressed by Equation 2:

\[
SNI = DPI \times SSI
\]  
Equation 2

where, SSI is derived from a weighted index related to lack of access of resources indicators in a community or neighborhood as shown in Reference Report #5, and DPI is given as occupants in uninhabitable buildings amplified by external and internal factors related to desirability to evacuate according to Equation 2
4.2 STEPS IN DEVELOPING THE MODEL

The process of developing the Shelter Needs Index consists of five main steps which should be passed in an iterative manner (Figure 6).

1. **Theoretical Concept**: Within the indicator development process the development of the theoretical indicator framework (step 1) contains the specification of the various dimensions to be covered, i.e. the sub-systems of the physical risk and social vulnerability as defined in Section 5.1 and explained in depth in Reference Report #5.

2. **Indicator Selection**: The second step is defining and populating the indicators for each sub-system according to the framework identified in step 1, and collection of the requisite data. In order to guarantee the quality of the composite indicator framework, the single sub-indicators should meet some quality standards. For example, indicators used should be reliable, accessible, reproducible, interpretable and accurate.

3. **Normalization**: Before aggregating the values of the sub-indicators into an overall composite indicator value, the sub-indicator values must be normalized (step 3). This is necessary because most of the sub-indicators have different units and cannot be combined into the indicator framework in their original values.

4. **Aggregation**: In the fourth step, the sub-indicators are combined together as a weighted sum which results in the form of one single aggregated index value, UDRI, and several sub-levels.

5. **Sensitivity Analysis**: Due to the difficulty in operationalizing all dimensions of vulnerability (i.e., some dimensions cannot be measured) and the high amount of underlying data, the results might also be affected by different sources of uncertainty. This applies also to the intra-model uncertainties associated with the weighting process and the implementation of transformation functions, but also the uncertainties contained within the input-data which can be substantial. Therefore, in order to analyse the robustness of the methodology, a sensitivity analysis which demonstrates variability of the results should be conducted as a final step.

4.3 IMPLEMENTING THE MODEL IN MCDA SOFTWARE

4.3.1 Theoretical concept - Creating the Decision Tree

Using the hierarchical “Tree View” in the MCDA software, under the View -> Frames Menu in the GUI, the Shelter Needs Index (SNI) framework can be implemented by sequentially defining the following options in the decision tree (Figure 7):

1. Define Goal: In this example, Shelter Needs Index (SNI) is defined as the main goal.
2. Add Alternatives to SNI: in this example case three Alternatives were added (SCD1, SCD2 and SCD3). These are the sub-city districts in the example for which the shelter needs is computed.

3. Add Criterion to Alternatives: The two sub-criterion as can be seen in the figure are added as Displaced Persons Index (DPI) and Shelter Seeking Index (SSI).

4. Add Sub-criterion to DPI: This is the Building Habitability Index (BHI) and the Desirability to Evacuate sub-criterion.

5. Add Sub-criterion to “Desirability to Evacuate” sub-criterion: Here we add four indicators describing this sub-criterion: 1) Ratio of Lone Parent Households with Children; 2) Proportion of Children (0-4); 3) Proportion of Elderly (65 and over); 4) Ratio of sub-standard dwellings lacking basic amenities. These are the indicators from the Urban Audit which describe the desire to evacuate sub-criterion (more on the choice for the selection of indicators can be found in Reference Report #5).

6. Add Sub-criterion to SSI: This is the Accessibility Index (AI) and the Desirability to seek public shelter sub-criterion.

7. Add Sub-criterion to “Desirability to seek public shelter” sub-criterion: Here we add four indicators describing this sub-criterion: 1) Migrants from low HDI countries; 2) Ratio of population under poverty line; 3) Ratio of low education population (below ISCED level 2); 4) Unemployment Ratio. These are the indicators from the Urban Audit which describe the desire to seek public shelter sub-criterion (more on the choice for the selection of indicators can be found in Reference Report #5).

Figure 7 Hierarchical Decision Criteria of Shelter Needs Model developed in MCDA using the "Tree View"
4.3.2 Populating the Data Matrix

Once the aggregated decision tree has been constructed in MCDA using the “Tree View” option (see Figure 8), the values for each of the Alternatives and Measures can be populated using the “Edit Data” feature from the “Data” Menu in the GUI. This brings up a hierarchical table which can be expanded fully and values for all of the indicators (measures) can be taken over from the Urban Audit or from input models, such as the OOFIMS model to compute BHI or the Accessibility model to compute the Accessibility Index (AI).

In this example, some fictional values are used as the indicators for each of the three different Sub City Districts (SCDs), and are entered into the Table (Figure 8).

![Hierarchical Data Matrix in MCDA which can be used to enter, and edit the raw and normalized value of each of the criteria measures](image)

4.3.3 Normalization

A normalization converts a measure’s levels into common units called utility. MCDA uses different types of transformation formulas (simple linear, adjusted simple linear, peak linear, quadratic, simple quadratic, adjusted simple quadratic, piecewise linear). Essentially, linear transformation functions straight lines and quadratic transformation functions are smooth curves. They can be either decreasing or increasing (depending on whether an indicator describes a vulnerability or a coping capacity). The only restrictions are that the least preferred Level of a measure must have a Utility (normalized value) of 0.0 and the most preferred level must have a SUF Utility of 1.0.

As can be seen in Figure 9, the values of the actual indicators are entered in their “raw form” which in turn are normalized and presented in the column indicating the transformed variables. By default a “Adjusted Linear Normalization” is used to transform the data. To change the transformation values the normalized values can be edited by clicking into a cell of the table. Right-clicking brings up a context popup. By choosing, “Criterion value function” the Normalization frame of the clicked criterion be activated where a normalization function can be defined.
4.3.4 Aggregation of Decision Criteria

After the decision tree has been developed, the aggregation functions between the various criterion and sub-criterion have to be defined. A criterion’s members are said to interact when a high utility on any one member results in a high utility for the goal or when a low utility on any one member results in a low overall utility for the goal. MCDA models interactions by defining a “weighted sum”, “weighted product” or by allowing the user to enter an “expression” under the Aggregator option for each of the criteria. The aggregator option can be accessed by right clicking on each of the criterion or sub-criterion from the decision tree (Figure 10). The following aggregators are defined for the Shelter Needs model according to the equations presented in section 5.1:

1) SNI: use the expression SNI = Weighted Product (to produce the equation SNI = SSI x DPI)
2) DPI: use the expression DPI = weighted_BHI * ( 1 + weighted_Criterion_Desirability_to_Evacuate )
3) SSI: use the expression SSI = weighted_AI * ( 1 + weighted_Criterion_Desirability_to_See_Public_Shelter )
4) Desirability to Evacuate (DE): use weighted sum aggregator
5) Desirability to Seek Public Shelter (SPS): use weighted sum aggregator
4.3.5 Assigning Weights

Using the Data -> Edit Importance menu from the GUI, the weights dialogue can be activated. Weights are a loose term for the scaling constants associated with the active members within a criterion or sub-criterion. Weights are not important by themselves, but do provide an indication of the relative indicators’ relative importances, given their ranges. All of MCDA weight computations are based on the ranges defined in the weight dialog boxes.

The weights for each criterion are defined by a Multi-Utility Function (MUF). A Multi-measure Utility Function (MUF) is the formula MCDA software uses to compute the utility (common units score) for an alternative on a goal based on the alternative's utilities on the goal's members. The formula combines the alternative's utilities on the goal's members using a weighted average, weighted product or other expressions as entered by the user in the previous step.

It should be noted that the weights for each MUF add to 100%. The values selected for the weights are shown in Figure 11, but can be changed interactively by the user for each MUF.
4.4 DISPLAYING RESULTS

4.4.1 Stacked Bar Chart

Ranks your alternatives with a stacked bar chart showing the contribution of the measures and/or goals to the results by selecting Plots -> Stacked Bar for Alternatives Menu. Each alternative's bar is made up of sub-bars that show the contribution from individual measures or goals. Alternatives with the minimum utility on a member will have no sub-bar for that member. Alternatives with the best utility on a member will have the longest sub-bar for the member. Members with more weight will have longer sub-bars. As shown in Figure XX, to display the stacked bar rankings for the main goal (SNI), the “up to tier 1” option has to be selected. The “sort” option will then rank the highest to lowest SCD from left to right. It can be seen in this example that SCD 1 has the highest shelter needs, as both the contribution of Displaced Persons (DPI) and Shelter Seeking population (SSI) are the highest in this SCD. By selecting “up to tier 1” and “up to tier 2” option the sub-criteria at each tier will be added to the stacked bar chart (Figure 12 and Figure 13, respectively).

Figure 12 The stacked bar ranking for SNI displayed up to tier 1
4.4.2 Criteria Importance

The weights for each of the criteria and the indicators composing cab be changed interactively by selecting the Data -> Edit Importance menu to bring up the weights dialogue box. Furthermore, by selecting Plots -> Criteria Importance from the drop down menu, the importance level (weights) of each of the criteria, sub criteria and measures describing these can be viewed for all the different tiers of the analysis in a cob-web chart (Figure 14). The importance of each of the criteria for the different alternatives can also be summarized by selecting Plots -> Pie Alternatives from the menu (Figure 15).
4.4.3 Analyzing Stability of Analysis

By selecting Plots -> Display Solutions Stability from the Menu in the GUI, the effect of changing a measure's or criteria's overall weight can be seen (Figure 16). When you select this option, MCDA displays a dialog box where you choose a criterion to analyze (e.g., DPI). You can also choose a normalized solution in the options. The options are to sort the alternatives in the key by Name, by their overall ranking or by their ranking on the selected criterion. The alternative lines are colored in the order they are shown in the key. As such, MCDA draws a graph showing the effect of varying the measure's (or goal's) percentage of the overall weight from 0 to 100 percent. The graph's horizontal axis is the criterion's percentage of the overall weight. At 100 percent weight the measure is the only concern and an alternative's overall ranking will match its ranking on the measure. At zero percent, the measure is not a concern and its weight is distributed among the other measures. A vertical line represents the measure's percentage of the overall weight in the active preference set.
Figure 16 A sensitivity graph in MCDA showing the sensitivity of the alternative’s ranking to the weights of DPI
References